Not getting GPU workunits

Message boards : Bug tracker : Not getting GPU workunits

To post messages, you must log in.

AuthorMessage
bryan

Send message
Joined: 7 Nov 17
Posts: 13
Credit: 75,580,956
RAC: 40,460
    
Message 798 - Posted: 27 Apr 2018, 4:46:06 UTC

Since I reinstalled I don't seem to get GPU workunits anymore..

Fri 27 Apr 2018 12:06:00 AM EDT | | CUDA: NVIDIA GPU 0: GeForce GTX 1050 (driver version 390.48, CUDA version 9.1, compute capability 6.1, 1997MB, 1926MB available, 1960 GFLOPS peak)
Fri 27 Apr 2018 12:06:00 AM EDT | Amicable Numbers | URL https://sech.me/boinc/Amicable/; Computer ID 37719; resource share 100
Fri 27 Apr 2018 12:06:00 AM EDT | | General prefs: from http://www.worldcommunitygrid.org/ (last modified 26-Sep-2017 00:16:23)
(I don't understand why it's getting prefs from wcg - I don't have it setup on this machine)
Fri 27 Apr 2018 12:06:00 AM EDT | | don't use GPU while active
Fri 27 Apr 2018 12:06:00 AM EDT | Amicable Numbers | Sending scheduler request: To fetch work.
Fri 27 Apr 2018 12:06:00 AM EDT | Amicable Numbers | Requesting new tasks for NVIDIA GPU
Fri 27 Apr 2018 12:06:03 AM EDT | Amicable Numbers | Scheduler request completed: got 0 new tasks

I've tried resetting the project which hasn't done much..
ID: 798 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Sergei Chernykh
Project administrator
Project developer

Send message
Joined: 5 Jan 17
Posts: 446
Credit: 72,451,573
RAC: 0
   
Message 799 - Posted: 27 Apr 2018, 5:24:27 UTC - in response to Message 798.  
Last modified: 27 Apr 2018, 5:24:41 UTC

Check your global BOINC client preferences. You have "Run GPU tasks if user is active" unset.
ID: 799 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bryan

Send message
Joined: 7 Nov 17
Posts: 13
Credit: 75,580,956
RAC: 40,460
    
Message 802 - Posted: 27 Apr 2018, 18:11:48 UTC - in response to Message 799.  

I've still gotten GPU tasks with that set before. I just turned that off in the project and locally and still got 0 tasks.
ID: 802 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile PDW

Send message
Joined: 25 Jan 17
Posts: 8
Credit: 1,062,994,003
RAC: 179
   
Message 803 - Posted: 27 Apr 2018, 18:55:18 UTC - in response to Message 798.  


Fri 27 Apr 2018 12:06:00 AM EDT | | General prefs: from http://www.worldcommunitygrid.org/ (last modified 26-Sep-2017 00:16:23)
(I don't understand why it's getting prefs from wcg - I don't have it setup on this machine)

I believe the general computing preferences propagate when the same email address is used (I assume basically CPID based).

Have you tried with just this project being the only one to request any work ?
ID: 803 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bryan

Send message
Joined: 7 Nov 17
Posts: 13
Credit: 75,580,956
RAC: 40,460
    
Message 805 - Posted: 28 Apr 2018, 15:20:46 UTC - in response to Message 803.  

that is part of the confusing bit.. I never set up http://www.worldcommunitygrid.org/ at all on this machine... it's not listed as a project..
ID: 805 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile PDW

Send message
Joined: 25 Jan 17
Posts: 8
Credit: 1,062,994,003
RAC: 179
   
Message 806 - Posted: 28 Apr 2018, 16:11:33 UTC - in response to Message 805.  

Doesn't need to be set up on that machine, the projects that are may have got their settings from WCG.
Even Amicable may have got your general settings from WCG since it says they were last set in 2017.
I haven't read anything that says the 'controlling' project has to be present on a machine for them to be used, all seems to be linked to CPID.

Did single project update (everything else NNT) not work ?
Can't see your machines so can't see details of Boinc/OS to suggest much else...
Is No_Alt_Platform set in cc_config ?
ID: 806 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bryan

Send message
Joined: 7 Nov 17
Posts: 13
Credit: 75,580,956
RAC: 40,460
    
Message 807 - Posted: 29 Apr 2018, 2:38:31 UTC - in response to Message 806.  

NNT?
Just updating the project didn't help. I forgot to mention I'm running a fresh install of Ubuntu 18.04.. whoops.. No_Alt_Platform in config.

I also tried resetting my web preferences in Amicable and my local ones.

Decided to try adding the two projects I had on previous install.. Einstein and WCG.. didn't help, but Einstein didn't get a GPU workunit either... and they automatically gave me a log (https://pastebin.ubuntu.com/p/KZbkZsXbDp/) I can login to see why:
2018-04-29 02:18:20.3951 [PID=29417] [debug] [HOST#12590263] MSG(high) No work sent
2018-04-29 02:18:20.3951 [PID=29417] [debug] [HOST#12590263] MSG(high) see scheduler log messages on https://einsteinathome.org/host/12590263/log
2018-04-29 02:18:20.3951 [PID=29417] [debug] [HOST#12590263] MSG(high) Binary Radio Pulsar Search (Arecibo) is not available for your type of computer.

I stopped BOINC and apt installed nvidia-opencl-dev libgl1-mesa-dev mesa-common-dev ocl-icd-opencl-dev opencl-c-headers clinfo, and then Einstein@Home immediately filled up the nVidia jobs.
(I installed clinfo first and gave output indicating everything was fine, but obviously not..)

I also decided that installing nvidia-cuda-dev might get it to work for Amicable, but will see after some of the E@H jobs finish.
ID: 807 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile PDW

Send message
Joined: 25 Jan 17
Posts: 8
Credit: 1,062,994,003
RAC: 179
   
Message 811 - Posted: 29 Apr 2018, 16:41:18 UTC - in response to Message 807.  

No New Tasks !

Ah, linux, you should have lead with that !!
ID: 811 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bryan

Send message
Joined: 7 Nov 17
Posts: 13
Credit: 75,580,956
RAC: 40,460
    
Message 812 - Posted: 30 Apr 2018, 3:39:45 UTC - in response to Message 811.  

Sorry :/, but yup it's working now with all the previously mentioned packages. Thanks for the assist.
ID: 812 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Bug tracker : Not getting GPU workunits


©2020 Sergei Chernykh