Somethings must be faulty -> AMD gpu usage at nearby 1-2 % ? Clueless..

Message boards : Number crunching : Somethings must be faulty -> AMD gpu usage at nearby 1-2 % ? Clueless..

To post messages, you must log in.

AuthorMessage
Rantanplan

Send message
Joined: 5 Mar 17
Posts: 8
Credit: 25,026,860
RAC: 0
   
Message 1162 - Posted: 13 Jun 2019, 8:10:45 UTC
Last modified: 13 Jun 2019, 8:57:31 UTC

ok, wus runnings time are very high on my machine.

Guess it use my gpu at 100% , but allmost no gpu usage is indicated.

Tried several drivers versions, but differences are noteiced by me.

Tried everthings betwen 16-21 header files, no difference.
Always the same -> to complete 50% (2 wus) it takes 3 hours.

I think it must be the wrong drivers version everytime,
but which should I use ?

Anybody there who's running a RX560 too ?

Greetings
ID: 1162 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Rantanplan

Send message
Joined: 5 Mar 17
Posts: 8
Credit: 25,026,860
RAC: 0
   
Message 1163 - Posted: 13 Jun 2019, 11:56:32 UTC - in response to Message 1162.  
Last modified: 13 Jun 2019, 12:56:20 UTC

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-blockchain-beta

Used this . Can't believe it but -> the almost approximately runtime for 2 wus at the same time
reduced to ~3 hours !?!

ok, I will see !
cpus = 0.5
gpus = 0.5

1h05m 30%
1h15m 33%
1h30m 37%

It's getting slower approximately could be around 4 hours , I think.
ID: 1163 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Rantanplan

Send message
Joined: 5 Mar 17
Posts: 8
Credit: 25,026,860
RAC: 0
   
Message 1164 - Posted: 13 Jun 2019, 14:39:29 UTC - in response to Message 1163.  
Last modified: 13 Jun 2019, 15:38:36 UTC

3h30m 68.6 % , and it's getting slower. *chewbacca sound*. dam...
I'll suspend them from crunching, and start over with some new ones...

ok, on the next two wus I'm running with
more cpu usage, means:

cpus = 0.80
gpus = 0.50


Running very wrong 5% in 30 minutes. No way !

Comeon, there must be a way faster ! Anybody out there ? I can't effort this to pay really !

! BIG HELP !
ID: 1164 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Kellen

Send message
Joined: 14 Nov 17
Posts: 70
Credit: 1,000,005,236
RAC: 0
   
Message 1165 - Posted: 13 Jun 2019, 23:54:35 UTC - in response to Message 1164.  

Hi Rantaplan,

This is normal behaviour for the workunits at this stage of the search to 1.0E20. The majority of the work is being performed by the CPU and is focused on generating a list of prime numbers over a range of approximately 5.5E12 which are then tested to determine whether they are the largest prime factor in an amicable pair. That test is what is done on the GPU and takes a very, very small amount of time compared to the amount of time required to find the large prime number.

For a long time the GPU tasks were increasing in runtime, however over the next few months they should begin to decrease in runtime slightly as the large prime range per task decreases in size. The CPU tasks are also becoming more efficient and should become significantly faster towards the end of the current search.

Until the search up to 1.0E21 begins, GPUs will not be fully utilized.

Regards,
Kellen
ID: 1165 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Rantanplan

Send message
Joined: 5 Mar 17
Posts: 8
Credit: 25,026,860
RAC: 0
   
Message 1166 - Posted: 14 Jun 2019, 12:07:36 UTC - in response to Message 1165.  
Last modified: 14 Jun 2019, 12:33:37 UTC

Great ! Thx , actualy I'm running better on cpu, even they use 3 to 4 cores.

Wish you a nice weekend !

Cheers !
ID: 1166 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
mikey
Avatar

Send message
Joined: 20 Feb 17
Posts: 19
Credit: 364,498,683
RAC: 1,058
   
Message 1167 - Posted: 14 Jun 2019, 20:57:22 UTC - in response to Message 1164.  

3h30m 68.6 % , and it's getting slower. *chewbacca sound*. dam...
I'll suspend them from crunching, and start over with some new ones...

ok, on the next two wus I'm running with
more cpu usage, means:

cpus = 0.80
gpus = 0.50


Running very wrong 5% in 30 minutes. No way !

Comeon, there must be a way faster ! Anybody out there ? I can't effort this to pay really !

! BIG HELP !


Change the cpu numbers back to 1.0 so it uses a whole cpu core and then run multiple gpu workunits at the same time, I'm running 6 on my 1060 and it;s barely reaching 10% but is banging them out in a little over 5.5 hours each. You use an app_config.xml file like this:

<app_config>
<app>
<name>amicable_10_20</name>
<max_concurrent>4</max_concurrent>
<report_results_immediately/>
<fraction_done_exact/>
<gpu_versions>
<gpu_usage>0.25</gpu_usage>
<cpu_usage>1</cpu_usage>
</gpu_versions>
</app>
</app_config>

Save the file as a txt type file, use Notepad in Windows, and save it to c:\programdata\boinc\projects\ the one with ammicable in the name. Change the <max_concurrent> line and the <gpu_usage line to run more wu's at one time. For instance to run 6 at one time you change the 4 to a 6 and change the 0.25 to 0.16, to run 8 at one time you change the 4 to an 8 and the percentage to 0.125, then open the Boinc Manager and click options, read config files. BE CAREFUL though as that will cause your existing wu's to restart from the beginning but you will be running 4 at one time or 6 or whatever. Experiment with how many you can run at one time before the time starts going up, then back off one wu.
ID: 1167 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Steve Dodd

Send message
Joined: 31 Jan 17
Posts: 19
Credit: 200,914,451
RAC: 0
   
Message 1177 - Posted: 22 Jun 2019, 23:27:57 UTC
Last modified: 22 Jun 2019, 23:29:47 UTC

For some reason, BOINC isn't registering my app_config file for Amicable Numbers project. File is located in the appropriate projects directory (D:\ProgramData\BOINC\projects\sech.me_boinc_Amicable), named app_config.xml, contents are:

<app_config>
<app>
<name>amicable_10_20</name>
<user_friendly_name>Amicable Numbers up to 10^20</user_friendly_name>
<non_cpu_intensive>0</non_cpu_intensive>
<max_concurrent>8</max_concurrent>
<report_results_immediately/>
<fraction_done_exact/>
<gpu_versions>
<gpu_usage>0.125</gpu_usage>
<cpu_usage>1</cpu_usage>
</gpu_versions>
</app>
</app_config>

No message about a syntax error:

...
6/22/2019 4:22:07 PM | | CUDA: NVIDIA GPU 0: GeForce GTX 1070 (driver version 398.82, CUDA version 9.2, compute capability 6.1, 4096MB, 3560MB available, 6852 GFLOPS peak)
6/22/2019 4:22:07 PM | | CUDA: NVIDIA GPU 1: GeForce GTX 1070 (driver version 398.82, CUDA version 9.2, compute capability 6.1, 4096MB, 3560MB available, 6852 GFLOPS peak)
6/22/2019 4:22:07 PM | | CUDA: NVIDIA GPU 2: GeForce GTX 1070 (driver version 398.82, CUDA version 9.2, compute capability 6.1, 4096MB, 3560MB available, 6561 GFLOPS peak)
6/22/2019 4:22:07 PM | | OpenCL: NVIDIA GPU 0: GeForce GTX 1070 (driver version 398.82, device version OpenCL 1.2 CUDA, 8192MB, 3560MB available, 6852 GFLOPS peak)
6/22/2019 4:22:07 PM | | OpenCL: NVIDIA GPU 1: GeForce GTX 1070 (driver version 398.82, device version OpenCL 1.2 CUDA, 8192MB, 3560MB available, 6852 GFLOPS peak)
6/22/2019 4:22:07 PM | | OpenCL: NVIDIA GPU 2: GeForce GTX 1070 (driver version 398.82, device version OpenCL 1.2 CUDA, 8192MB, 3560MB available, 6561 GFLOPS peak)
6/22/2019 4:22:08 PM | | Host name: (removed)
6/22/2019 4:22:08 PM | | Processor: 48 GenuineIntel Genuine Intel(R) CPU 0000 @ 2.20GHz [Family 6 Model 79 Stepping 0]
6/22/2019 4:22:08 PM | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 fma cx16 sse4_1 sse4_2 movebe popcnt aes f16c rdrandsyscall nx lm avx avx2 vmx smx tm2 dca pbe fsgsbase bmi1 hle smep bmi2
6/22/2019 4:22:08 PM | | OS: Microsoft Windows 10: Professional x64 Edition, (10.00.17763.00)
6/22/2019 4:22:08 PM | | Memory: 31.89 GB physical, 41.64 GB virtual
6/22/2019 4:22:08 PM | | Disk: 465.76 GB total, 436.92 GB free
6/22/2019 4:22:08 PM | | Local time is UTC -7 hours
6/22/2019 4:22:08 PM | | No WSL found.
6/22/2019 4:22:08 PM | | VirtualBox version: 5.2.22
6/22/2019 4:22:08 PM | Asteroids@home | Found app_config.xml
6/22/2019 4:22:08 PM | CAS@home | Found app_config.xml
6/22/2019 4:22:08 PM | Cosmology@Home | Found app_config.xml
6/22/2019 4:22:08 PM | DENIS@Home | Found app_config.xml
6/22/2019 4:22:08 PM | Distributed Hardware Evolution Project | Found app_config.xml
6/22/2019 4:22:08 PM | GoofyxGrid@Home CPU | Found app_config.xml
6/22/2019 4:22:08 PM | latinsquares | Found app_config.xml
6/22/2019 4:22:08 PM | Leiden Classical | Found app_config.xml
6/22/2019 4:22:08 PM | Moo! Wrapper | Found app_config.xml
6/22/2019 4:22:08 PM | nanoHUB_at_home | Found app_config.xml
6/22/2019 4:22:08 PM | NFS@Home | Found app_config.xml
6/22/2019 4:22:08 PM | NumberFields@home | Found app_config.xml
6/22/2019 4:22:08 PM | odlk | Found app_config.xml
6/22/2019 4:22:08 PM | PrimeGrid | Found app_config.xml
6/22/2019 4:22:08 PM | SZTAKI Desktop Grid | Found app_config.xml
6/22/2019 4:22:08 PM | TN-Grid Platform | Found app_config.xml
6/22/2019 4:22:08 PM | Universe@Home | Found app_config.xml
6/22/2019 4:22:08 PM | VGTU project@Home | Found app_config.xml
6/22/2019 4:22:08 PM | World Community Grid | Found app_config.xml
6/22/2019 4:22:08 PM | XANSONS for COD | Found app_config.xml
6/22/2019 4:22:08 PM | yoyo@home | Found app_config.xml
6/22/2019 4:22:08 PM | | Config: report completed tasks immediately
6/22/2019 4:22:08 PM | | Config: use all coprocessors
6/22/2019 4:22:08 PM | | Last benchmark was 797 days 07:52:37 ago
6/22/2019 4:22:08 PM | Albert@Home | URL https://albert.phys.uwm.edu/; Computer ID 21062; resource share 1
6/22/2019 4:22:08 PM | Amicable Numbers | URL https://sech.me/boinc/Amicable/; Computer ID 78743; resource share 100
...

Anyone see what I've obviously overlooked?
ID: 1177 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Number crunching : Somethings must be faulty -> AMD gpu usage at nearby 1-2 % ? Clueless..


©2022 Sergei Chernykh